Debian DSA-1281-1 : clamav - several vulnerabilities

High Nessus Plugin ID 25098

Synopsis

The remote Debian host is missing a security-related update.

Description

Several remote vulnerabilities have been discovered in the Clam anti-virus toolkit. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-1745 It was discovered that a file descriptor leak in the CHM handler may lead to denial of service.

- CVE-2007-1997 It was discovered that a buffer overflow in the CAB handler may lead to the execution of arbitrary code.

- CVE-2007-2029 It was discovered that a file descriptor leak in the PDF handler may lead to denial of service.

Solution

Upgrade the clamav packages. Packages for the arm, sparc, m68k, mips and mipsel architectures are not yet available. They will be provided later.

For the oldstable distribution (sarge) these problems have been fixed in version 0.84-2.sarge.16.

For the stable distribution (etch) these problems have been fixed in version 0.90.1-3etch1.

See Also

https://security-tracker.debian.org/tracker/CVE-2007-1745

https://security-tracker.debian.org/tracker/CVE-2007-1997

https://security-tracker.debian.org/tracker/CVE-2007-2029

https://www.debian.org/security/2007/dsa-1281

Plugin Details

Severity: High

ID: 25098

File Name: debian_DSA-1281.nasl

Version: 1.19

Type: local

Agent: unix

Published: 2007/04/30

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:clamav, cpe:/o:debian:debian_linux:3.1, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2007/04/25

Reference Information

CVE: CVE-2007-1745, CVE-2007-1997, CVE-2007-2029

DSA: 1281

CWE: 399