GLSA-200704-15 : MadWifi: Multiple vulnerabilities

High Nessus Plugin ID 25060


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200704-15 (MadWifi: Multiple vulnerabilities)

The driver does not properly process Channel Switch Announcement Information Elements, allowing for an abnormal channel change. The ieee80211_input() function does not properly handle AUTH frames and the driver sends unencrypted packets before WPA authentication succeeds.
Impact :

A remote attacker could send specially crafted AUTH frames to the vulnerable host, resulting in a Denial of Service by crashing the kernel. A remote attacker could gain access to sensitive information about network architecture by sniffing unencrypted packets. A remote attacker could also send a Channel Switch Count less than or equal to one to trigger a channel change, resulting in a communication loss and a Denial of Service.
Workaround :

There is no known workaround at this time.


All MadWifi users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-wireless/madwifi-ng-0.9.3'

See Also

Plugin Details

Severity: High

ID: 25060

File Name: gentoo_GLSA-200704-15.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/04/19

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:madwifi-ng, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/04/17

Vulnerability Publication Date: 2007/03/19

Reference Information

CVE: CVE-2006-7178, CVE-2006-7179, CVE-2006-7180

OSVDB: 34643, 34644, 34645, 34646

GLSA: 200704-15