GLSA-200704-13 : File: Denial of Service

High Nessus Plugin ID 25058


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200704-13 (File: Denial of Service)

Conor Edberg discovered an error in the way file processes a specific regular expression.
Impact :

A remote attacker could entice a user to open a specially crafted file, using excessive CPU ressources and possibly leading to a Denial of Service. Note that this vulnerability could be also triggered through an automatic file scanner like amavisd-new.
Workaround :

There is no known workaround at this time.


All file users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/file-4.20-r1'

See Also

Plugin Details

Severity: High

ID: 25058

File Name: gentoo_GLSA-200704-13.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/04/19

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:file, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/04/17

Vulnerability Publication Date: 2007/04/18

Reference Information

CVE: CVE-2007-2026

OSVDB: 34995

GLSA: 200704-13