GLSA-200704-12 : Multiple vulnerabilities

High Nessus Plugin ID 25057


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200704-12 ( Multiple vulnerabilities)

John Heasman of NGSSoftware has discovered a stack-based buffer overflow in the StarCalc parser and an input validation error when processing metacharacters in a link. Also OpenOffice.Org includes code from libwpd making it vulnerable to heap-based overflows when converting WordPerfect document tables (GLSA 200704-07).
Impact :

A remote attacker could entice a user to open a specially crafted document, possibly leading to execution of arbitrary code with the rights of the user running
Workaround :

There is no known workaround at this time.


All users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-2.1.0-r1' All binary users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-bin-2.2.0'

See Also

Plugin Details

Severity: High

ID: 25057

File Name: gentoo_GLSA-200704-12.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/04/19

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openoffice, p-cpe:/a:gentoo:linux:openoffice-bin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/04/16

Vulnerability Publication Date: 2007/03/16

Reference Information

CVE: CVE-2007-0002, CVE-2007-0238, CVE-2007-0239

OSVDB: 33315, 33971, 33972

GLSA: 200704-12

CWE: 119