GLSA-200704-09 : xine-lib: Heap-based buffer overflow

High Nessus Plugin ID 25054


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200704-09 (xine-lib: Heap-based buffer overflow)

xine-lib does not check boundaries on data being read into buffers from DMO video files in code that is shared with MPlayer (DMO_VideoDecoder.c).
Impact :

An attacker could entice a user to play a specially crafted DMO video file with a player using xine-lib, potentially resulting in the execution of arbitrary code with the privileges of the user running the player.
Workaround :

There is no known workaround at this time.


All xine-lib users on the x86 platform should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/xine-lib-1.1.4-r2'

See Also

Plugin Details

Severity: High

ID: 25054

File Name: gentoo_GLSA-200704-09.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2007/04/19

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xine-lib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list, Host/Gentoo/arch

Patch Publication Date: 2007/04/14

Reference Information

CVE: CVE-2007-1246

GLSA: 200704-09

CWE: 119