Opera < 9.20 Multiple Vulnerabilities

medium Nessus Plugin ID 25036
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is susceptible to multiple issues.

Description

The version of Opera installed on the remote host reportedly may allow a remote attacker to bypass cross-site scripting filters because it renders a web page without a defined charset with the charset of the parent page.

In addition, its FTP implementation can be leveraged by remote attackers to force the client to connect to arbitrary servers via FTP PASV responses.

Solution

Upgrade to Opera version 9.20 or later.

See Also

http://bindshell.net/papers/ftppasv

http://www.hardened-php.net/advisory_032007.142.html

http://web.archive.org/web/20080516192212/http://www.opera.com/support/search/view/855/

Plugin Details

Severity: Medium

ID: 25036

File Name: opera_920.nasl

Version: 1.18

Type: local

Agent: windows

Family: Windows

Published: 4/14/2007

Updated: 11/15/2018

Dependencies: opera_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version_UI

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2/23/2007

Reference Information

CVE: CVE-2007-1114, CVE-2007-1115, CVE-2007-1563

BID: 22701, 23089, 41927

CWE: 79