GLSA-200704-07 : libwpd: Multiple vulnerabilities

High Nessus Plugin ID 25020


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200704-07 (libwpd: Multiple vulnerabilities)

libwpd contains heap-based overflows in two functions that convert WordPerfect document tables. In addition, it contains an integer overflow in a text-conversion function.
Impact :

An attacker could entice a user to convert a specially crafted WordPerfect file, resulting in a crash or possibly the execution of arbitrary code with the rights of the user running libwpd.
Workaround :

There is no known workaround at this time.


All libwpd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/libwpd-0.8.9'

See Also

Plugin Details

Severity: High

ID: 25020

File Name: gentoo_GLSA-200704-07.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/04/10

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libwpd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/04/06

Reference Information

CVE: CVE-2007-0002, CVE-2007-1466

BID: 23006

GLSA: 200704-07

CWE: 119, 189