Sun OpenOffice.org < 2.2 Multiple Vulnerabilities

High Nessus Plugin ID 25004

Synopsis

The remote Windows host has a program that may be affected by multiple vulnerabilities.

Description

The remote host is running a version of Sun Microsystems OpenOffice.org that is prior to version 2.2. It is, therefore, affected by a stack-based buffer overflow vulnerability in its handling of StarCalc documents. If a remote attacker can trick a user into opening a specially crafted StarCalc document, the attacker can execute arbitrary code on the remote host subject to the user's privileges.

In addition, versions 2.0 - 2.1 reportedly have a heap-based buffer overflow vulnerability that can be triggered when importing a specially crafted WordPerfect document, resulting in arbitrary code execution.

Solution

Upgrade to Sun Microsystems OpenOffice.org version 2.2 or later.

See Also

https://seclists.org/bugtraq/2007/Apr/88

http://www.openoffice.org/security/cves/CVE-2007-2.html

http://www.openoffice.org/security/cves/CVE-2007-0238.html

http://www.openoffice.org/security/cves/CVE-2007-0239.html

Plugin Details

Severity: High

ID: 25004

File Name: openoffice_220.nasl

Version: 1.22

Type: local

Agent: windows

Family: Windows

Published: 2007/04/06

Updated: 2018/11/15

Dependencies: 25551

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:sun:openoffice.org

Required KB Items: SMB/OpenOffice/Build

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2007/03/16

Reference Information

CVE: CVE-2007-0002, CVE-2007-0238, CVE-2007-1466

BID: 23006, 23067

CWE: 119, 189