Mandrake Linux Security Advisory : kdelibs (MDKSA-2007:076)

Medium Nessus Plugin ID 24942


The remote Mandrake Linux host is missing one or more security updates.


A bug was discovered in KJS where UTF8 decoding did not reject overlong sequences. This vulnerability is similar to that discovered by Andreas Nolden in QT3 and QT4, but at this current time there is no known exploit for this issue.

Updated packages have been patched to address this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 24942

File Name: mandrake_MDKSA-2007-076.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/04/05

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:kdelibs-common, p-cpe:/a:mandriva:linux:kdelibs-devel-doc, p-cpe:/a:mandriva:linux:lib64kdecore4, p-cpe:/a:mandriva:linux:lib64kdecore4-devel, p-cpe:/a:mandriva:linux:libkdecore4, p-cpe:/a:mandriva:linux:libkdecore4-devel, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/04/03

Reference Information

CVE: CVE-2007-0242

MDKSA: 2007:076