GLSA-200703-25 : Ekiga: Format string vulnerability

Critical Nessus Plugin ID 24930


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200703-25 (Ekiga: Format string vulnerability)

Mu Security has discovered that Ekiga fails to implement formatted printing correctly.
Impact :

An attacker could exploit this vulnerability to crash Ekiga and potentially execute arbitrary code by sending a specially crafted Q.931 SETUP packet to a victim.
Workaround :

There is no known workaround at this time.


All Ekiga users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-voip/ekiga-2.0.7'

See Also

Plugin Details

Severity: Critical

ID: 24930

File Name: gentoo_GLSA-200703-25.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/04/05

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ekiga, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/03/29

Vulnerability Publication Date: 2007/02/13

Reference Information

CVE: CVE-2007-1006

BID: 22613

OSVDB: 31939

GLSA: 200703-25