RHEL 3 / 4 : openoffice.org (RHSA-2007:0033)

High Nessus Plugin ID 24896


The remote Red Hat host is missing one or more security updates.


Updated openoffice.org packages to correct security issues are now available for Red Hat Enterprise Linux 3 and 4.

This update has been rated as having important security impact by the Red Hat Security Response Team.

OpenOffice.org is an office productivity suite that includes desktop applications such as a word processor, spreadsheet, presentation manager, formula editor, and drawing program.

iDefense reported an integer overflow flaw in libwpd, a library used internally to OpenOffice.org for handling Word Perfect documents. An attacker could create a carefully crafted Word Perfect file that could cause OpenOffice.org to crash or possibly execute arbitrary code if the file was opened by a victim. (CVE-2007-1466)

John Heasman discovered a stack overflow in the StarCalc parser in OpenOffice.org. An attacker could create a carefully crafted StarCalc file that could cause OpenOffice.org to crash or possibly execute arbitrary code if the file was opened by a victim. (CVE-2007-0238)

Flaws were discovered in the way OpenOffice.org handled hyperlinks. An attacker could create an OpenOffice.org document which could run commands if a victim opened the file and clicked on a malicious hyperlink. (CVE-2007-0239)

All users of OpenOffice.org are advised to upgrade to these updated packages, which contain backported fixes for these issues.

Red Hat would like to thank Fridrich Strba for alerting us to the issue CVE-2007-1466 and providing a patch, and John Heasman for CVE-2007-0238.


Update the affected packages.

See Also





Plugin Details

Severity: High

ID: 24896

File Name: redhat-RHSA-2007-0033.nasl

Version: $Revision: 1.20 $

Type: local

Agent: unix

Published: 2007/03/26

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:openoffice.org, p-cpe:/a:redhat:enterprise_linux:openoffice.org-i18n, p-cpe:/a:redhat:enterprise_linux:openoffice.org-kde, p-cpe:/a:redhat:enterprise_linux:openoffice.org-libs, cpe:/o:redhat:enterprise_linux:3, cpe:/o:redhat:enterprise_linux:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/03/22

Vulnerability Publication Date: 2007/03/16

Reference Information

CVE: CVE-2007-0238, CVE-2007-0239, CVE-2007-1466

BID: 22812, 23006, 23067

OSVDB: 33315, 33971, 33972

RHSA: 2007:0033

CWE: 189