Mandrake Linux Security Advisory : openafs (MDKSA-2007:066)

High Nessus Plugin ID 24892


The remote Mandrake Linux host is missing one or more security updates.


By default, OpenAFS prior to 1.44 and 1.5.17 supports setuid programs within the local cell, which could allow attackers to obtain privileges.

Updated packages have been patched to address this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 24892

File Name: mandrake_MDKSA-2007-066.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/03/26

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:dkms-libafs, p-cpe:/a:mandriva:linux:lib64openafs1, p-cpe:/a:mandriva:linux:lib64openafs1-devel, p-cpe:/a:mandriva:linux:libopenafs1, p-cpe:/a:mandriva:linux:libopenafs1-devel, p-cpe:/a:mandriva:linux:openafs, p-cpe:/a:mandriva:linux:openafs-client, p-cpe:/a:mandriva:linux:openafs-doc, p-cpe:/a:mandriva:linux:openafs-server, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/03/20

Reference Information

CVE: CVE-2007-1507

MDKSA: 2007:066