Debian DSA-1270-2 : openoffice.org - several vulnerabilities

High Nessus Plugin ID 24879

Synopsis

The remote Debian host is missing a security-related update.

Description

Several security related problems have been discovered in OpenOffice.org, the free office suite. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-0002 iDefense reported several integer overflow bugs in libwpd, a library for handling WordPerfect documents that is included in OpenOffice.org. Attackers are able to exploit these with carefully crafted WordPerfect files that could cause an application linked with libwpd to crash or possibly execute arbitrary code.

- CVE-2007-0238 Next Generation Security discovered that the StarCalc parser in OpenOffice.org contains an easily exploitable stack overflow that could be used by a specially crafted document to execute arbitrary code.

- CVE-2007-0239 It has been reported that OpenOffice.org does not escape shell meta characters and is hence vulnerable to execute arbitrary shell commands via a specially crafted document after the user clicked to a prepared link.

This updated advisory only provides packages for the upcoming etch release alias Debian GNU/Linux 4.0.

Solution

Upgrade the OpenOffice.org packages.

For the stable distribution (sarge) these problems have been fixed in version 1.1.3-9sarge6.

See Also

https://security-tracker.debian.org/tracker/CVE-2007-0002

https://security-tracker.debian.org/tracker/CVE-2007-0238

https://security-tracker.debian.org/tracker/CVE-2007-0239

http://www.debian.org/security/2007/dsa-1270

Plugin Details

Severity: High

ID: 24879

File Name: debian_DSA-1270.nasl

Version: 1.18

Type: local

Agent: unix

Published: 2007/03/26

Updated: 2018/08/09

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openoffice.org, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Vulnerability Publication Date: 2007/03/21

Reference Information

CVE: CVE-2007-0002, CVE-2007-0238, CVE-2007-0239

DSA: 1270

CWE: 119