Mandrake Linux Security Advisory : libwpd (MDKSA-2007:063)

High Nessus Plugin ID 24842


The remote Mandrake Linux host is missing one or more security updates.


iDefense reported several overflow bugs in libwpd. An attacker could create a carefully crafted Word Perfect file that could cause an application linked with libwpd, such as OpenOffice, to crash or possibly execute arbitrary code if the file was opened by a victim.

Updated packages have been patched to address this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 24842

File Name: mandrake_MDKSA-2007-063.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/03/18

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64wpd-0.8_8, p-cpe:/a:mandriva:linux:lib64wpd-0.8_8-devel, p-cpe:/a:mandriva:linux:libwpd-0.8_8, p-cpe:/a:mandriva:linux:libwpd-0.8_8-devel, p-cpe:/a:mandriva:linux:libwpd-tools, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/03/16

Reference Information

CVE: CVE-2007-0002, CVE-2007-1466

MDKSA: 2007:063

CWE: 119, 189