GLSA-200703-14 : Asterisk: SIP Denial of Service

High Nessus Plugin ID 24839


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200703-14 (Asterisk: SIP Denial of Service)

The MU Security Research Team discovered that Asterisk contains a NULL pointer dereferencing error in the SIP channel when handling request messages.
Impact :

A remote attacker could cause an Asterisk server listening for SIP messages to crash by sending a specially crafted SIP request message.
Workaround :

There is no known workaround at this time.


All Asterisk users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose net-misc/asterisk Note: Asterisk 1.0.x is no longer supported upstream so users should consider upgrading to Asterisk 1.2.x.

See Also

Plugin Details

Severity: High

ID: 24839

File Name: gentoo_GLSA-200703-14.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/03/18

Modified: 2015/08/06

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:asterisk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/03/16

Vulnerability Publication Date: 2007/03/04

Reference Information

CVE: CVE-2007-1306

OSVDB: 33888

GLSA: 200703-14