Mandrake Linux Security Advisory : kdelibs (MDKSA-2007:054)

High Nessus Plugin ID 24804


The remote Mandrake Linux host is missing one or more security updates.


ecma/kjs_html.cpp in KDE JavaScript (KJS), as used in Konqueror, allows remote attackers to cause a denial of service (crash) by accessing the content of an iframe with an ftp:// URI in the src attribute, probably due to a NULL pointer dereference.

Updated packages have been patched to address this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 24804

File Name: mandrake_MDKSA-2007-054.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/03/12

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:kdelibs-common, p-cpe:/a:mandriva:linux:kdelibs-devel-doc, p-cpe:/a:mandriva:linux:lib64kdecore4, p-cpe:/a:mandriva:linux:lib64kdecore4-devel, p-cpe:/a:mandriva:linux:libkdecore4, p-cpe:/a:mandriva:linux:libkdecore4-devel, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/03/08

Reference Information

CVE: CVE-2007-1308, CVE-2007-1565

MDKSA: 2007:054

CWE: 399