GLSA-200703-10 : KHTML: XSS (XSS) vulnerability

Medium Nessus Plugin ID 24802

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200703-10 (KHTML: XSS (XSS) vulnerability)

The KHTML code allows for the execution of JavaScript code located inside the 'Title' HTML element, a related issue to the Safari error found by Jose Avila.
Impact :

When viewing a HTML page that renders unsanitized attacker-supplied input in the page title, Konqueror and other parts of KDE will execute arbitrary JavaScript code contained in the page title, allowing for the theft of browser session data or cookies.
Workaround :

There is no known workaround at this time.

Solution

All KDElibs users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=kde-base/kdelibs-3.5.5-r8'

See Also

https://security.gentoo.org/glsa/200703-10

Plugin Details

Severity: Medium

ID: 24802

File Name: gentoo_GLSA-200703-10.nasl

Version: 1.15

Type: local

Published: 2007/03/12

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:kdelibs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/03/10

Vulnerability Publication Date: 2007/01/23

Reference Information

CVE: CVE-2007-0478, CVE-2007-0537

GLSA: 200703-10

CWE: 79