Debian DSA-1265-1 : mozilla - several vulnerabilities

High Nessus Plugin ID 24794

Synopsis

The remote Debian host is missing a security-related update.

Description

Several security related problems have been discovered in Mozilla and derived products. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities :

- CVE-2006-6497 Several vulnerabilities in the layout engine allow remote attackers to cause a denial of service and possibly permit them to execute arbitrary code. [MFSA 2006-68]

- CVE-2006-6498 Several vulnerabilities in the JavaScript engine allow remote attackers to cause a denial of service and possibly permit them to execute arbitrary code. [MFSA 2006-68]

- CVE-2006-6499 A bug in the js_dtoa function allows remote attackers to cause a denial of service. [MFSA 2006-68]

- CVE-2006-6501 'shutdown' discovered a vulnerability that allows remote attackers to gain privileges and install malicious code via the watch JavaScript function. [MFSA 2006-70]

- CVE-2006-6502 Steven Michaud discovered a programming bug that allows remote attackers to cause a denial of service. [MFSA 2006-71]

- CVE-2006-6503 'moz_bug_r_a4' reported that the src attribute of an IMG element could be used to inject JavaScript code. [MFSA 2006-72]

- CVE-2006-6505 Georgi Guninski discovered several heap-based buffer overflows that allow remote attackers to execute arbitrary code. [MFSA 2006-74]

Solution

Upgrade the Mozilla and Iceape packages.

For the stable distribution (sarge) these problems have been fixed in version 1.7.8-1sarge10.

See Also

https://security-tracker.debian.org/tracker/CVE-2006-6497

https://security-tracker.debian.org/tracker/CVE-2006-6498

https://security-tracker.debian.org/tracker/CVE-2006-6499

https://security-tracker.debian.org/tracker/CVE-2006-6501

https://security-tracker.debian.org/tracker/CVE-2006-6502

https://security-tracker.debian.org/tracker/CVE-2006-6503

https://security-tracker.debian.org/tracker/CVE-2006-6505

http://www.debian.org/security/2007/dsa-1265

Plugin Details

Severity: High

ID: 24794

File Name: debian_DSA-1265.nasl

Version: 1.20

Type: local

Agent: unix

Published: 2007/03/12

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mozilla, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/03/10

Vulnerability Publication Date: 2006/12/19

Reference Information

CVE: CVE-2006-6497, CVE-2006-6498, CVE-2006-6499, CVE-2006-6501, CVE-2006-6502, CVE-2006-6503, CVE-2006-6505

BID: 21668