Google Desktop Advanced Search Internal Web Server XSS

High Nessus Plugin ID 24710


The remote host has an application installed that is vulnerable to a local cross-site scripting attack.


The version of Google Desktop installed on the remote host is affected by a cross-site scripting flaw because it fails to properly encode the output for the 'under' keyword. This issue cannot be directly exploited remotely; however, when used in conjunction with a known cross-site scripting vulnerability to extract the unique signature associated with Google Desktop software, it might allow an attacker to query a victim's system for sensitive information.


Google Desktop automatically updates itself when a new version of the software is available. However, in some cases it may not be able to update itself due to network connectivity issues. Please ensure that Google Desktop version 5.0.0701.30540 or later is installed.

See Also

Plugin Details

Severity: High

ID: 24710

File Name: google_desktop_xss_flaw.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2007/02/26

Modified: 2016/05/16

Dependencies: 24709

Risk Information

Risk Factor: High


Base Score: 7.6

Temporal Score: 6.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:desktop

Required KB Items: SMB/Google/Google Dektop/version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/02/21

Vulnerability Publication Date: 2007/02/22

Reference Information

CVE: CVE-2007-1085

BID: 22650

OSVDB: 33483

CERT: 615857

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990