Mandrake Linux Security Advisory : gd (MDKSA-2007:035)

High Nessus Plugin ID 24648


The remote Mandrake Linux host is missing one or more security updates.


Buffer overflow in the gdImageStringFTEx function in gdft.c in the GD Graphics Library 2.0.33 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted string with a JIS encoded font.

Packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 24648

File Name: mandrake_MDKSA-2007-035.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/02/18

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gd-utils, p-cpe:/a:mandriva:linux:lib64gd2, p-cpe:/a:mandriva:linux:lib64gd2-devel, p-cpe:/a:mandriva:linux:lib64gd2-static-devel, p-cpe:/a:mandriva:linux:libgd2, p-cpe:/a:mandriva:linux:libgd2-devel, p-cpe:/a:mandriva:linux:libgd2-static-devel, cpe:/o:mandriva:linux:2006, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/02/06

Reference Information

CVE: CVE-2007-0455

MDKSA: 2007:035

CWE: 119