Mandrake Linux Security Advisory : xine-ui (MDKSA-2007:027)

Critical Nessus Plugin ID 24641


The remote Mandrake Linux host is missing one or more security updates.


Format string vulnerability in the errors_create_window function in errors.c in xine-ui allows attackers to execute arbitrary code via unknown vectors. (CVE-2007-0254)

XINE 0.99.4 allows user-assisted remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a certain M3U file that contains a long #EXTINF line and contains format string specifiers in an invalid udp:// URI, possibly a variant of CVE-2007-0017. (CVE-2007-0255)

The updated packages have been patched to correct these issues.


Update the affected xine-ui, xine-ui-aa and / or xine-ui-fb packages.

Plugin Details

Severity: Critical

ID: 24641

File Name: mandrake_MDKSA-2007-027.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/02/18

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:xine-ui, p-cpe:/a:mandriva:linux:xine-ui-aa, p-cpe:/a:mandriva:linux:xine-ui-fb, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/01/26

Reference Information

CVE: CVE-2007-0254, CVE-2007-0255

BID: 22002

MDKSA: 2007:027