Mandrake Linux Security Advisory : mono (MDKSA-2006:234)

Medium Nessus Plugin ID 24617


The remote Mandrake Linux host is missing one or more security updates.


XSP (the Mono ASP.NET server) is vulnerable to source disclosure attack which allow a malicious user to obtain the source code of the server-side application. This vulnerability grants the attacker deeper knowledge of the Web application logic.

Updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 24617

File Name: mandrake_MDKSA-2006-234.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/02/18

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:jay, p-cpe:/a:mandriva:linux:lib64mono0, p-cpe:/a:mandriva:linux:lib64mono0-devel, p-cpe:/a:mandriva:linux:libmono-runtime, p-cpe:/a:mandriva:linux:libmono0, p-cpe:/a:mandriva:linux:libmono0-devel, p-cpe:/a:mandriva:linux:mono, p-cpe:/a:mandriva:linux:mono-data-sqlite, p-cpe:/a:mandriva:linux:mono-doc, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/12/20

Reference Information

CVE: CVE-2006-6104

BID: 21687

MDKSA: 2006:234