Mandrake Linux Security Advisory : ImageMagick (MDKSA-2006:193)

Medium Nessus Plugin ID 24578


The remote Mandrake Linux host is missing one or more security updates.


Multiple buffer overflows in GraphicsMagick before 1.1.7 and ImageMagick 6.0.7 allow user-assisted attackers to cause a denial of service and possibly execute execute arbitrary code via (1) a DCM image that is not properly handled by the ReadDCMImage function in coders/dcm.c, or (2) a PALM image that is not properly handled by the ReadPALMImage function in coders/palm.c.

Updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 24578

File Name: mandrake_MDKSA-2006-193.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/02/18

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ImageMagick, p-cpe:/a:mandriva:linux:ImageMagick-doc, p-cpe:/a:mandriva:linux:lib64Magick10.4.0, p-cpe:/a:mandriva:linux:lib64Magick10.4.0-devel, p-cpe:/a:mandriva:linux:lib64Magick8.4.2, p-cpe:/a:mandriva:linux:lib64Magick8.4.2-devel, p-cpe:/a:mandriva:linux:libMagick10.4.0, p-cpe:/a:mandriva:linux:libMagick10.4.0-devel, p-cpe:/a:mandriva:linux:libMagick8.4.2, p-cpe:/a:mandriva:linux:libMagick8.4.2-devel, p-cpe:/a:mandriva:linux:perl-Image-Magick, cpe:/o:mandriva:linux:2006, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/10/30

Reference Information

CVE: CVE-2006-5456

BID: 20707

MDKSA: 2006:193