Mandrake Linux Security Advisory : python (MDKSA-2006:181)

High Nessus Plugin ID 24566


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability in python's repr() function was discovered by Benjamin C. Wiley Sittler. It was found that the function did not properly handle UTF-32/UCS-4 strings, so an application that used repr() on certin untrusted data could possibly be exploited to execute arbitrary code with the privileges of the user running the python application.

Updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 24566

File Name: mandrake_MDKSA-2006-181.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/02/18

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64python2.4, p-cpe:/a:mandriva:linux:lib64python2.4-devel, p-cpe:/a:mandriva:linux:libpython2.4, p-cpe:/a:mandriva:linux:libpython2.4-devel, p-cpe:/a:mandriva:linux:python, p-cpe:/a:mandriva:linux:python-base, p-cpe:/a:mandriva:linux:python-docs, p-cpe:/a:mandriva:linux:tkinter, cpe:/o:mandriva:linux:2006, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/10/10

Reference Information

CVE: CVE-2006-4980

MDKSA: 2006:181