avast! Server Edition LHA Archive Extended-header Field Processing Overflow

High Nessus Plugin ID 24281


The remote Windows host contains an application that is affected by a buffer overflow.


The remote host is running avast! Server Edition.

The installed version of avast! Server Edition is reportedly prone to a heap overflow when processing LHA archives with long filename and directory-name extended-header fields. An attacker may be able to exploit this issue to execute arbitrary code on the remote host, likely with LOCAL SYSTEM privileges.


Upgrade to avast! Server Edition 4.7.660 or later.

See Also



Plugin Details

Severity: High

ID: 24281

File Name: avast_lha_overflow.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2007/02/06

Modified: 2016/05/04

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:U/RC:ND

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2006/09/07

Reference Information

CVE: CVE-2006-4626

BID: 19903

OSVDB: 28612