GLSA-200701-09 : oftpd: Denial of Service

High Nessus Plugin ID 24207


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200701-09 (oftpd: Denial of Service)

By specifying an unsupported address family in the arguments to a LPRT or LPASV command, an assertion in oftpd will cause the daemon to abort.
Impact :

Remote, unauthenticated attackers may be able to terminate any oftpd process, denying service to legitimate users.
Workaround :

There is no known workaround at this time.


All oftpd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-ftp/oftpd-0.3.7-r3'

See Also

Plugin Details

Severity: High

ID: 24207

File Name: gentoo_GLSA-200701-09.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/01/17

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:oftpd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/01/15

Vulnerability Publication Date: 2007/01/16

Reference Information

CVE: CVE-2006-6767

OSVDB: 32822

GLSA: 200701-09