GLSA-200701-07 : OpenOffice.org: EMF/WMF file handling vulnerabilities

high Nessus Plugin ID 24205
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200701-07 (OpenOffice.org: EMF/WMF file handling vulnerabilities)

John Heasman of NGSSoftware has discovered integer overflows in the EMR_POLYPOLYGON and EMR_POLYPOLYGON16 processing and an error within the handling of META_ESCAPE records.
Impact :

An attacker could exploit these vulnerabilities to cause heap overflows and potentially execute arbitrary code with the privileges of the user running OpenOffice.org by enticing the user to open a document containing a malicious WMF/EMF file.
Workaround :

There is no known workaround known at this time.

Solution

All OpenOffice.org binary users should update to version 2.1.0 or later:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-bin-2.1.0' All OpenOffice.org users should update to version 2.0.4 or later:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-2.0.4'

See Also

https://security.gentoo.org/glsa/200701-07

Plugin Details

Severity: High

ID: 24205

File Name: gentoo_GLSA-200701-07.nasl

Version: 1.15

Type: local

Published: 1/17/2007

Updated: 1/6/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openoffice, p-cpe:/a:gentoo:linux:openoffice-bin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 1/12/2007

Vulnerability Publication Date: 1/4/2007

Reference Information

CVE: CVE-2006-5870

GLSA: 200701-07