Fedora Core 4 : ruby-1.8.4-3.fc4 (2006-842)

High Nessus Plugin ID 24155


The remote Fedora Core host is missing a security update.


- Thu Jul 20 2006 Akira TAGOH <tagoh at redhat.com> - 1.8.4-3

- security fixes [CVE-2006-3694]

- ruby-1.8.4-fix-insecure-dir-operation.patch :

- ruby-1.8.4-fix-insecure-regexp-modification.patch:
fixed the insecure operations in the certain safe-level restrictions. (#199538)

- ruby-1.8.4-fix-alias-safe-level.patch: fixed to not bypass the certain safe-level restrictions. (#199543)

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

See Also


Plugin Details

Severity: High

ID: 24155

File Name: fedora_2006-842.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2007/01/17

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:irb, p-cpe:/a:fedoraproject:fedora:rdoc, p-cpe:/a:fedoraproject:fedora:ri, p-cpe:/a:fedoraproject:fedora:ruby, p-cpe:/a:fedoraproject:fedora:ruby-debuginfo, p-cpe:/a:fedoraproject:fedora:ruby-devel, p-cpe:/a:fedoraproject:fedora:ruby-docs, p-cpe:/a:fedoraproject:fedora:ruby-libs, p-cpe:/a:fedoraproject:fedora:ruby-mode, p-cpe:/a:fedoraproject:fedora:ruby-tcltk, cpe:/o:fedoraproject:fedora_core:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2006/07/22

Reference Information

FEDORA: 2006-842