Fedora Core 4 : kernel-2.6.17-1.2142_FC4 (2006-801)

High Nessus Plugin ID 24144


The remote Fedora Core host is missing a security update.


Rebase to latest upstream -stable release, which fixes a security issue which could result in local priveledge escalation.

More details at:

In addition, an optimisation was performed to use significantly less memory for several heavily used kernel data structures.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

See Also



Plugin Details

Severity: High

ID: 24144

File Name: fedora_2006-801.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2007/01/17

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:kernel, p-cpe:/a:fedoraproject:fedora:kernel-debuginfo, p-cpe:/a:fedoraproject:fedora:kernel-devel, p-cpe:/a:fedoraproject:fedora:kernel-doc, p-cpe:/a:fedoraproject:fedora:kernel-smp, p-cpe:/a:fedoraproject:fedora:kernel-smp-devel, cpe:/o:fedoraproject:fedora_core:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2006/07/14

Reference Information

FEDORA: 2006-801