Fedora Core 5 : busybox-1.01-3.fc5 (2006-510)

High Nessus Plugin ID 24098


The remote Fedora Core host is missing a security update.


The BusyBox passwd command does not use a proper salt when generating passwords. This would create an instance where a brute-force attack could take very little time. This problem is fixed in busybox-1.01-3.fc5.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected busybox, busybox-anaconda and / or busybox-debuginfo packages.

See Also


Plugin Details

Severity: High

ID: 24098

File Name: fedora_2006-510.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2007/01/17

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:busybox, p-cpe:/a:fedoraproject:fedora:busybox-anaconda, p-cpe:/a:fedoraproject:fedora:busybox-debuginfo, cpe:/o:fedoraproject:fedora_core:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2006/05/04

Reference Information

FEDORA: 2006-510