Fedora Core 6 : libgsf-1.14.1-7 (2006-1417)

High Nessus Plugin ID 24068


The remote Fedora Core host is missing a security update.


Fixes a heap overflow in libgsf. When a specially crafted OLE document is opened, it can overflow a buffer possibly leading to arbitrary code execution.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected libgsf, libgsf-debuginfo and / or libgsf-devel packages.

See Also


Plugin Details

Severity: High

ID: 24068

File Name: fedora_2006-1417.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2007/01/17

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:libgsf, p-cpe:/a:fedoraproject:fedora:libgsf-debuginfo, p-cpe:/a:fedoraproject:fedora:libgsf-devel, cpe:/o:fedoraproject:fedora_core:6

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2006/12/07

Reference Information

FEDORA: 2006-1417