Fedora Core 5 : qt-3.3.7-0.1.fc5 (2006-1056)

Medium Nessus Plugin ID 24035


The remote Fedora Core host is missing a security update.


A security flaw was recently discovered in the way Qt 3.x pixmap images. This issue can occur only when transforming specially prepared images from untrusted sources. Qt 3.3.7 corrects this flaw.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

See Also


Plugin Details

Severity: Medium

ID: 24035

File Name: fedora_2006-1056.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2007/01/17

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.4

Temporal Score: 4.2

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:qt, p-cpe:/a:fedoraproject:fedora:qt-MySQL, p-cpe:/a:fedoraproject:fedora:qt-ODBC, p-cpe:/a:fedoraproject:fedora:qt-PostgreSQL, p-cpe:/a:fedoraproject:fedora:qt-config, p-cpe:/a:fedoraproject:fedora:qt-debuginfo, p-cpe:/a:fedoraproject:fedora:qt-designer, p-cpe:/a:fedoraproject:fedora:qt-devel, cpe:/o:fedoraproject:fedora_core:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/10/24

Reference Information

BID: 20599

FEDORA: 2006-1056