GLSA-200612-20 : imlib2: Multiple vulnerabilities

Medium Nessus Plugin ID 23957

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200612-20 (imlib2: Multiple vulnerabilities)

M. Joonas Pihlaja discovered several buffer overflows in loader_argb.c, loader_png.c, loader_lbm.c, loader_jpeg.c, loader_tiff.c, loader_tga.c, loader_pnm.c and an out-of-bounds memory read access in loader_tga.c.
Impact :

An attacker can entice a user to process a specially crafted JPG, ARGB, PNG, LBM, PNM, TIFF, or TGA image with an 'imlib2*' binary or another application using the imlib2 libraries. Successful exploitation of the buffer overflows causes the execution of arbitrary code with the permissions of the user running the application.
Workaround :

There is no known workaround at this time.

Solution

All imlib2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/imlib2-1.3.0'

See Also

https://security.gentoo.org/glsa/200612-20

Plugin Details

Severity: Medium

ID: 23957

File Name: gentoo_GLSA-200612-20.nasl

Version: 1.12

Type: local

Published: 2006/12/30

Updated: 2018/08/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:imlib2, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/12/20

Vulnerability Publication Date: 2006/11/06

Reference Information

CVE: CVE-2006-4806, CVE-2006-4807, CVE-2006-4808, CVE-2006-4809

GLSA: 200612-20