Mandrake Linux Security Advisory : wireshark (MDKSA-2006:152)

Medium Nessus Plugin ID 23898


The remote Mandrake Linux host is missing one or more security updates.


Vulnerabilities in the SCSI, DHCP, and SSCOP dissectors were discovered in versions of wireshark less than 0.99.3, as well as an off-by-one error in the IPsec ESP preference parser if compiled with ESP decryption support.

This updated provides wireshark 0.99.3a which is not vulnerable to these issues.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 23898

File Name: mandrake_MDKSA-2006-152.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/12/16

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64wireshark0, p-cpe:/a:mandriva:linux:libwireshark0, p-cpe:/a:mandriva:linux:tshark, p-cpe:/a:mandriva:linux:wireshark, p-cpe:/a:mandriva:linux:wireshark-tools, cpe:/o:mandriva:linux:2006

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/08/25

Reference Information

CVE: CVE-2006-4330, CVE-2006-4331, CVE-2006-4332, CVE-2006-4333

MDKSA: 2006:152

CWE: 399