Mandrake Linux Security Advisory : ruby (MDKSA-2006:134)

Medium Nessus Plugin ID 23884


The remote Mandrake Linux host is missing one or more security updates.


A number of flaws were discovered in the safe-level restrictions in the Ruby language. Because of these flaws, it would be possible for an attacker to create a carefully crafted malicious script that could allow them to bypass certain safe-level restrictions.

Updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 23884

File Name: mandrake_MDKSA-2006-134.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/12/16

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:U/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ruby, p-cpe:/a:mandriva:linux:ruby-devel, p-cpe:/a:mandriva:linux:ruby-doc, p-cpe:/a:mandriva:linux:ruby-tk, cpe:/o:mandriva:linux:2006

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/07/28

Reference Information

CVE: CVE-2006-3694

BID: 18944

MDKSA: 2006:134