GLSA-200612-17 : GNU Radius: Format string vulnerability

Critical Nessus Plugin ID 23874


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200612-17 (GNU Radius: Format string vulnerability)

A format string vulnerability was found in the sqllog function from the SQL accounting code for radiusd. That function is only used if one or more of the 'postgresql', 'mysql' or 'odbc' USE flags are enabled, which is not the default, except for the 'server' 2006.1 and 2007.0 profiles which enable the 'mysql' USE flag.
Impact :

An unauthenticated remote attacker could execute arbitrary code with the privileges of the user running radiusd, which may be the root user.
It is important to note that there is no default GNU Radius user for Gentoo systems because no init script is provided with the package.
Workaround :

There is no known workaround at this time.


All GNU Radius users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-dialup/gnuradius-1.4'

See Also

Plugin Details

Severity: Critical

ID: 23874

File Name: gentoo_GLSA-200612-17.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2006/12/16

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gnuradius, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/12/14

Reference Information

CVE: CVE-2006-4181

GLSA: 200612-17