GLSA-200612-16 : Links: Arbitrary Samba command execution

High Nessus Plugin ID 23873


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200612-16 (Links: Arbitrary Samba command execution)

Teemu Salmela discovered that Links does not properly validate 'smb://' URLs when it runs smbclient commands.
Impact :

A remote attacker could entice a user to browse to a specially crafted 'smb://' URL and execute arbitrary Samba commands, which would allow the overwriting of arbitrary local files or the upload or the download of arbitrary files. This vulnerability can be exploited only if 'smbclient' is installed on the victim's computer, which is provided by the 'samba' Gentoo package.
Workaround :

There is no known workaround at this time.


All Links users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/links-2.1_pre26'

See Also

Plugin Details

Severity: High

ID: 23873

File Name: gentoo_GLSA-200612-16.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/12/16

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:links, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/12/14

Vulnerability Publication Date: 2006/11/15

Reference Information

CVE: CVE-2006-5925

OSVDB: 30437

GLSA: 200612-16