GLSA-200612-15 : McAfee VirusScan: Insecure DT_RPATH

Medium Nessus Plugin ID 23867


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200612-15 (McAfee VirusScan: Insecure DT_RPATH)

Jakub Moc of Gentoo Linux discovered that McAfee VirusScan was distributed with an insecure DT_RPATH which included the current working directory, rather than $ORIGIN which was probably intended.
Impact :

An attacker could entice a VirusScan user to scan an arbitrary file and execute arbitrary code with the privileges of the VirusScan user by tricking the dynamic loader into loading an untrusted ELF DSO. An automated system, such as a mail scanner, may be subverted to execute arbitrary code with the privileges of the process invoking VirusScan.
Workaround :

Do not scan files or execute VirusScan from an untrusted working directory.


As VirusScan verifies that it has not been modified before executing, it is not possible to correct the DT_RPATH. Furthermore, this would violate the license that VirusScan is distributed under. For this reason, the package has been masked in Portage pending the resolution of this issue.
# emerge --ask --verbose --unmerge 'app-antivirus/vlnx'

See Also

Plugin Details

Severity: Medium

ID: 23867

File Name: gentoo_GLSA-200612-15.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/12/14

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:vlnx, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/12/14

Vulnerability Publication Date: 2006/12/14

Reference Information

CVE: CVE-2006-6474

OSVDB: 31295

GLSA: 200612-15