GLSA-200612-10 : Tar: Directory traversal vulnerability

Medium Nessus Plugin ID 23862


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200612-10 (Tar: Directory traversal vulnerability)

Tar does not properly extract archive elements using the GNUTYPE_NAMES record name, allowing files to be created at arbitrary locations using symlinks. Once a symlink is extracted, files after the symlink in the archive will be extracted to the destination of the symlink.
Impact :

An attacker could entice a user to extract a specially crafted tar archive, possibly allowing for the overwriting of arbitrary files on the system extracting the archive.
Workaround :

There is no known workaround at this time.


All Tar users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/tar-1.16-r2'

See Also

Plugin Details

Severity: Medium

ID: 23862

File Name: gentoo_GLSA-200612-10.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2006/12/14

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tar, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/12/11

Vulnerability Publication Date: 2006/11/21

Reference Information

CVE: CVE-2006-6097

OSVDB: 30721

GLSA: 200612-10