GLSA-200612-07 : Mozilla Firefox: Multiple vulnerabilities

High Nessus Plugin ID 23859

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200612-07 (Mozilla Firefox: Multiple vulnerabilities)

Mozilla Firefox improperly handles Script objects while they are being executed. Mozilla Firefox has also been found to be vulnerable to various possible buffer overflows. Lastly, the binary release of Mozilla Firefox is vulnerable to a low exponent RSA signature forgery issue because it is bundled with a vulnerable version of NSS.
Impact :

An attacker could entice a user to view specially crafted JavaScript and execute arbitrary code with the rights of the user running Mozilla Firefox. An attacker could also entice a user to view a specially crafted web page that causes a buffer overflow and again executes arbitrary code. It is also possible for an attacker to make up SSL/TLS certificates that would not be detected as invalid by the binary release of Mozilla Firefox, raising the possibility for Man-in-the-Middle attacks.
Workaround :

There is no known workaround at this time.

Solution

All Mozilla Firefox users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/mozilla-firefox-1.5.0.8' All Mozilla Firefox binary release users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/mozilla-firefox-bin-1.5.0.8'

See Also

https://security.gentoo.org/glsa/200612-07

Plugin Details

Severity: High

ID: 23859

File Name: gentoo_GLSA-200612-07.nasl

Version: 1.16

Type: local

Published: 2006/12/14

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mozilla-firefox, p-cpe:/a:gentoo:linux:mozilla-firefox-bin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/12/10

Vulnerability Publication Date: 2006/09/14

Reference Information

CVE: CVE-2006-5462, CVE-2006-5463, CVE-2006-5464, CVE-2006-5747, CVE-2006-5748

BID: 19849

GLSA: 200612-07