Adobe Reader < 8.0 AcroPDF ActiveX Control Multiple Vulnerabilities

High Nessus Plugin ID 23776


The remote Windows host has an ActiveX control that is affected by arbitrary code execution vulnerabilities.


The remote host contains a version of the 'AcroPDF' ActiveX control included with Adobe Reader and Acrobat.

The version of this ActiveX control on the remote host reportedly exposes several methods that fail to handle malformed arguments. If an attacker can trick a user on the affected host into visiting a specially crafted web page, he can leverage these issues to execute arbitrary code on the host subject to the user's privileges.


Either upgrade to Adobe Reader 8.0 or replace the version of 'AcroPDF.dll' as described in the vendor bulletin referenced above.

See Also

Plugin Details

Severity: High

ID: 23776

File Name: adobe_acropdf_activex_mult_vulns.nasl

Version: $Revision: 1.17 $

Type: local

Agent: windows

Family: Windows

Published: 2006/12/07

Modified: 2015/01/12

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:W/RC:ND

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/12/05

Vulnerability Publication Date: 2006/11/30

Reference Information

CVE: CVE-2006-6027, CVE-2006-6236

BID: 21155, 21338, 21813

OSVDB: 31057, 31058