GLSA-200611-20 : GNU gv: Stack overflow

Medium Nessus Plugin ID 23728


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200611-20 (GNU gv: Stack overflow)

GNU gv does not properly boundary check user-supplied data before copying it into process buffers.
Impact :

An attacker could entice a user to open a specially crafted document with GNU gv and execute arbitrary code with the rights of the user on the system.
Workaround :

There is no known workaround at this time.


All gv users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/gv-3.6.2-r1'

See Also

Plugin Details

Severity: Medium

ID: 23728

File Name: gentoo_GLSA-200611-20.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/11/27

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gv, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/11/24

Vulnerability Publication Date: 2006/11/10

Exploitable With

Core Impact

Reference Information

CVE: CVE-2006-5864

BID: 20978

OSVDB: 30274

GLSA: 200611-20