GLSA-200611-18 : TIN: Multiple buffer overflows

High Nessus Plugin ID 23726


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200611-18 (TIN: Multiple buffer overflows)

Urs Janssen and Aleksey Salow have reported multiple buffer overflows in TIN. Additionally, the OpenPKG project has reported an allocation off-by-one flaw which can lead to a buffer overflow.
Impact :

An attacker could entice a TIN user to read a specially crafted news article, and execute arbitrary code with the rights of the user running TIN.
Workaround :

There is no known workaround at this time.


All TIN users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-nntp/tin-1.8.2'

See Also

Plugin Details

Severity: High

ID: 23726

File Name: gentoo_GLSA-200611-18.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/11/27

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/11/24

Vulnerability Publication Date: 2006/11/24

Reference Information

CVE: CVE-2006-0804

BID: 16728

OSVDB: 35376

GLSA: 200611-18