Debian DSA-1212-1 : openssh - Denial of service

High Nessus Plugin ID 23661

Synopsis

The remote Debian host is missing a security-related update.

Description

Two denial of service problems have been found in the OpenSSH server.
The Common Vulnerabilities and Exposures project identifies the following vulnerabilities :

- CVE-2006-4924 The sshd support for ssh protocol version 1 does not properly handle duplicate incoming blocks. This could allow a remote attacker to cause sshd to consume significant CPU resources leading to a denial of service.

- CVE-2006-5051 A signal handler race condition could potentially allow a remote attacker to crash sshd and could theoretically lead to the ability to execute arbitrary code.

Solution

Upgrade the openssh package.

For the stable distribution (sarge), these problems have been fixed in version 1:3.8.1p1-8.sarge.6.

For the unstable and testing distributions, these problems have been fixed in version 1:4.3p2-4.

See Also

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=392428

https://security-tracker.debian.org/tracker/CVE-2006-4924

https://security-tracker.debian.org/tracker/CVE-2006-5051

http://www.debian.org/security/2006/dsa-1212

Plugin Details

Severity: High

ID: 23661

File Name: debian_DSA-1212.nasl

Version: 1.18

Type: local

Agent: unix

Published: 2006/11/20

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openssh, cpe:/o:debian:debian_linux:3.1

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/11/15

Vulnerability Publication Date: 2006/09/25

Reference Information

CVE: CVE-2006-4924, CVE-2006-5051

BID: 20216, 20241

DSA: 1212

CWE: 362, 399