GLSA-200610-09 : libmusicbrainz: Multiple buffer overflows

High Nessus Plugin ID 22920


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200610-09 (libmusicbrainz: Multiple buffer overflows)

Luigi Auriemma reported a possible buffer overflow in the MBHttp::Download function of lib/http.cpp as well as several possible buffer overflows in lib/rdfparse.c.
Impact :

A remote attacker could be able to execute arbitrary code or cause Denial of Service by making use of an overly long 'Location' header in an HTTP redirect message from a malicious server or a long URL in malicious RDF feeds.
Workaround :

There is no known workaround at this time.


All libmusicbrainz users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/musicbrainz-2.1.4'

See Also

Plugin Details

Severity: High

ID: 22920

File Name: gentoo_GLSA-200610-09.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/10/25

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:musicbrainz, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/10/22

Vulnerability Publication Date: 2006/08/13

Reference Information

CVE: CVE-2006-4197

OSVDB: 27944, 27945

GLSA: 200610-09