GLSA-200610-10 : ClamAV: Multiple Vulnerabilities

High Nessus Plugin ID 22913


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200610-10 (ClamAV: Multiple Vulnerabilities)

Damian Put and an anonymous researcher reported a potential heap-based buffer overflow vulnerability in rebuildpe.c responsible for the rebuilding of an unpacked PE file, and a possible crash in chmunpack.c in the CHM unpacker.
Impact :

By sending a malicious attachment to a mail server running ClamAV, or providing a malicious file to ClamAV through any other method, a remote attacker could cause a Denial of Service and potentially the execution of arbitrary code with the permissions of the user running ClamAV.
Workaround :

There is no known workaround at this time.


All ClamAV users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-antivirus/clamav-0.88.5'

See Also

Plugin Details

Severity: High

ID: 22913

File Name: gentoo_GLSA-200610-10.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/10/25

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:clamav, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/10/24

Vulnerability Publication Date: 2006/10/15

Reference Information

CVE: CVE-2006-4182

OSVDB: 29773, 29774

GLSA: 200610-10