Opera < 9.02 Multiple Vulnerabilities

Medium Nessus Plugin ID 22875


The remote host contains a web browser that is susceptible to a heap- based buffer overflow attack.


The version of Opera installed on the remote host reportedly contains a heap-based buffer overflow vulnerability that can be triggered by a long link. Successful exploitation of this issue may result in a crash of the application or even allow for execution of arbitrary code subject to the user's privileges.


Upgrade to Opera version 9.02 or later.

See Also




Plugin Details

Severity: Medium

ID: 22875

File Name: opera_902.nasl

Version: $Revision: 1.17 $

Type: local

Agent: windows

Family: Windows

Published: 2006/10/18

Modified: 2016/11/02

Dependencies: 21746

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version_UI

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2006/10/17

Reference Information

CVE: CVE-2006-4819

BID: 20591

OSVDB: 29785