GLSA-200609-17 : OpenSSH: Denial of Service

High Nessus Plugin ID 22464


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200609-17 (OpenSSH: Denial of Service)

Tavis Ormandy of the Google Security Team discovered a Denial of Service vulnerability in the SSH protocol version 1 CRC compensation attack detector.
Impact :

A remote unauthenticated attacker may be able to trigger excessive CPU usage by sending a pathological SSH message, denying service to other legitimate users or processes.
Workaround :

The system administrator may disable SSH protocol version 1 in /etc/ssh/sshd_config.


All OpenSSH users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/openssh-4.3_p2-r5'

See Also

Plugin Details

Severity: High

ID: 22464

File Name: gentoo_GLSA-200609-17.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/09/28

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openssh, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/09/27

Vulnerability Publication Date: 2006/09/25

Reference Information

CVE: CVE-2006-4924

BID: 20216

OSVDB: 29152

GLSA: 200609-17

CWE: 399