GLSA-200609-14 : ImageMagick: Multiple Vulnerabilities

Medium Nessus Plugin ID 22458


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200609-14 (ImageMagick: Multiple Vulnerabilities)

Tavis Ormandy of the Google Security Team discovered a stack and heap buffer overflow in the GIMP XCF Image decoder and multiple heap and integer overflows in the SUN bitmap decoder. Damian Put discovered a heap overflow in the SGI image decoder.
Impact :

An attacker may be able to create a specially crafted image that, when processed with ImageMagick, executes arbitrary code with the privileges of the executing user.
Workaround :

There is no known workaround at this time.


All ImageMagick users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/imagemagick-'

See Also

Plugin Details

Severity: Medium

ID: 22458

File Name: gentoo_GLSA-200609-14.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/09/27

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:imagemagick, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/09/26

Vulnerability Publication Date: 2006/08/14

Reference Information

CVE: CVE-2006-3743, CVE-2006-3744, CVE-2006-4144

BID: 19507, 19697, 19699

OSVDB: 27951, 28204, 28205

GLSA: 200609-14