MS06-055: Vulnerability in Vector Markup Language Could Allow Remote Code Execution (925486)

High Nessus Plugin ID 22449


Arbitrary code can be executed on the remote host through the email client or the web browser.


The remote host is running a version of Internet Explorer or Outlook Express that is vulnerable to a bug in the Vector Markup Language (VML) handling routine that could allow an attacker execute arbitrary code on the remote host by sending a specially crafted email or by luring a user on the remote host into visiting a rogue website.


Microsoft has released a set of patches for Windows 2000, XP and 2003.

See Also

Plugin Details

Severity: High

ID: 22449

File Name: smb_nt_ms06-055.nasl

Version: $Revision: 1.40 $

Type: local

Agent: windows

Published: 2006/09/26

Modified: 2017/08/10

Dependencies: 57033, 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/09/26

Vulnerability Publication Date: 2006/09/18

Exploitable With


Core Impact

Metasploit (MS06-055 Microsoft Internet Explorer VML Fill Method Code Execution)

Reference Information

CVE: CVE-2006-4868

BID: 20096

OSVDB: 28946

CERT: 416092

MSFT: MS06-055

MSKB: 925486